summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorRoger Gonzalez <roger@rogs.me>2024-03-09 10:22:32 -0300
committerRoger Gonzalez <roger@rogs.me>2024-03-09 10:22:32 -0300
commit787e90907fe09e83545284bff7f140c08b25fe12 (patch)
tree1154bcb4376c8b77f7ef06df4db7d111ceb24f0d /pyproject.toml
parent9faa1b9a7b5c0ba712369de9acbd375bafda13af (diff)
Added tests
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f5da613..0842466 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -22,6 +22,8 @@ classifiers = [
python = "^3.9"
pysrt = "^1.1.2"
chardet = "^5.2.0"
+pytest = "^8.1.1"
+pytest-cov = "^4.1.0"
[tool.poetry.group.dev.dependencies]
python-lsp-server = "^1.10.0"
@@ -79,3 +81,8 @@ max-args = 6
[tool.ruff.lint.pydocstyle]
convention = "pep257"
+
+[tool.pytest.ini_options]
+pythonpath = [
+ "."
+]